Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Program interrupt in RRTMG LW CLWRF interpolated GHG with Segmentation fault (signal 11)

jkqian

New member
The strange thing is that I run my program at other times without problems, but in July 2019, he always keeps interrupting without detailed error reporting information, and the interrupt points are usually
RRTMG LW CLWRF interpolated GHG values year: 2019 Julian day: 182.270142
I've tried almost every possible option on the Internet, but none of them have solved my problem. I set ghg_option to 0 and it didn't work either.
I also try to increase the thickness of the first vertical layer, and while this sometimes allows me to run longer, it eventually breaks down.
Is this some kind of bug and what should I do to solve it?
 

Attachments

  • namelist.input
    4.4 KB · Views: 6
There are a few issues here:

(1) cu_physics = 0, 0, 0, ===> pleas return on cumulus scheme at least for D01
(2) mp_physics = 4, 4, 6, ===>microphysics should be the same for all domains
(3) with p_top = 1000, 33 vertical levels are too small. Please increase the number to above 40
(4) gwd option should be turned of for 1km domain.

Please correct the above options, then try again.
 
There are a few issues here:

(1) cu_physics = 0, 0, 0, ===> pleas return on cumulus scheme at least for D01
(2) mp_physics = 4, 4, 6, ===>microphysics should be the same for all domains
(3) with p_top = 1000, 33 vertical levels are too small. Please increase the number to above 40
(4) gwd option should be turned of for 1km domain.

Please correct the above options, then try again.
Thank you very much for your advice, I will try again, besides I found another strange fact. If I run it from 0:00, the program will report an error around 8:00, whereas if I start at 6:00, there is no problem at all.
 
There are a few issues here:

(1) cu_physics = 0, 0, 0, ===> pleas return on cumulus scheme at least for D01
(2) mp_physics = 4, 4, 6, ===>microphysics should be the same for all domains
(3) with p_top = 1000, 33 vertical levels are too small. Please increase the number to above 40
(4) gwd option should be turned of for 1km domain.

Please correct the above options, then try again.
These changes did not work, attached are the nameslist and rsl files for this time
 

Attachments

  • namelist.input
    3.8 KB · Views: 0
  • rsl.error.zip
    2.1 MB · Views: 0
Top