Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

(RESOLVED) Cannot open file './PFILE:2020-09-13_00': Invalid argument

This post was from a previous version of the WRF&MPAS-A Support Forum. New replies have been disabled and if you have follow up questions related to this post, then please start a new thread from the forum home page.


New member
I am running ungrid.exe, and getting the following error.

At line 147 of file output.f90 (unit = 13)
Fortran runtime error: Cannot open file './PFILE:2020-09-13_00': Invalid argument
Error termination. Backtrace:
#0 0x7fc55ea1acd1 in ???
#1 0x7fc55ea1b819 in ???
#2 0x7fc55ea1c4ef in ???
#3 0x7fc55ec588b6 in ???
#4 0x7fc55ec58bac in ???
#5 0x55f2b2147109 in ???
#6 0x55f2b2145a1a in ???
#7 0x55f2b214604c in ???
#8 0x7fc55e6c60b2 in ???
#9 0x55f2b213f82d in ???
#10 0xffffffffffffffff in ???

any help is appreciated
This error clearly indicates that you don't have GFS data for the time 2020-09-13_00.
Please double check your GRIB files and enamelist.wps, make sure that ALL GFS data are available for the period specified in namelist.wps.
: As you can see I do have files in place and linked to the GFSs. I checked the input dates of namelist.wps, that looks fine. But still, I am getting the error.
Would you please double check the file gfs.t00z.pgrb2.0p50.f000, and find what time it is for?
Please try the command
wgrib -s gfs.t00z.pgrb2.0p50.f000
or if you are familiar with NCL,
ncl_convert2nc gfs.t00z.pgrb2.0p50.f000
Then look at the netCDF file.

I am having the exact same problem:

At line 147 of file output.f90 (unit = 13)
Fortran runtime error: Cannot open file './PFILE:2016-10-06_00': Invalid argument

Error termination. Backtrace:
#0 0x7f5c189abd01 in ???
#1 0x7f5c189ac849 in ???
#2 0x7f5c189ad52f in ???
#3 0x7f5c18bec5a6 in ???
#4 0x7f5c18bec89c in ???
#5 0x55b4e3b1e22f in ???
#6 0x55b4e3b1cb21 in ???
#7 0x55b4e3b1d172 in ???
#8 0x7f5c186560b2 in ???
#9 0x55b4e3b1683d in ???
#10 0xffffffffffffffff in ???

Everything seems to be linked in the correct way (link.png)

I checked and one of the files contains the information related to that date. (grib.txt).

Any help will be greatly appreciated.


  • link}.png
    268.6 KB · Views: 1,458
  • grib.txt
    30.9 KB · Views: 50
I first would like to apologize for the long delay in response. I've been traveling for a few weeks and am just now catching up with forum inquiries. Thank you for your patience. Can you attach your namelist.wps and ungrib.log file, along with one of your input data files? Thanks!
Im so sorry I didn't read your response before.

Thank you so much, but I found the problem. I was running the model in a external disk and for some reason I didnt have the permissions to open the files. When I run the model in home, everything worked out.

Thank you so much!