Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Running error with WRFV4.3 & WUDAPT LCZ

Z_wendy

New member
Hi, all.

I am running WRFV4.3 with WUDAPT LCZ land use data (41 LU_INDEX). When I ran WRF with sf_urban_physics=2, there was a bad termination message.

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x2B9C9A8046D7
#1 0x2B9C9A804D1E
#2 0x2B9C9C5F53FF
#3 0x13DD7B8 in __module_sf_bep_MOD_long_rad

I have tried many ways (e.g., adjust the time step, check the input data, and change the physics schemes and processor numbers) but failed to solve it. I also wonder how to read the above error.

Appreciated with any helps!

Thank you,
Wendy
 
Last edited:
Update:

Now I have run the model successfully. There might be two useful measures to solve it:
1. set "feedback=0" in namelist.input.
2. use High performance computing (HPC) to run the model in case of memory problems.

Thanks for any other ideas.
 
I have a similar error using version 4.4.1 using wudapt-lcz with surface physics 3 . I saw you post and trying to run again changing feedback to 0but as always have the me error at time step 6 hours.

d01 2022-05-30_06:00:00 module_io.F: in wrf_write_field

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x14e1f3e23ad0 in ???
#1 0x14e1f3e22c35 in ???
#2 0x14e1f324251f in ???
Wonder if you have a hint or share some settings of your namelist?
 
@fipoucat
Your error may not be related to the same issue. Can you attach your namelist.input file, as well as your rsl.error* files (package the rsl files together in a single *.TAR file)? Thanks!
 
@fipoucat
Of course, I can share the namelist.input file here. Hope it helps.
Actually, I also tried many other ways before, including adjusting the time step and physical schemes, but they didn't work. I guess this problem may be mainly related to the machine performance.
 

Attachments

  • namelist.input
    5 KB · Views: 9
attached the namelist I am using. THe WRF version is 4.4.1,there is a problem using version 4.4.2 with wudapt-lcz. tar file from rsl.error too big (74Mb).
 
Last edited:
@fipoucat
One issue may be that you're probably not using enough processors for the size of your domain (specifically d02). Take a look at this FAQ that discusses choosing an appropriate number of processors, based on the size of your domain.

I also notice you are running WRF-Chem. If increasing the number of processors doesn't help, I would recommend posting your question in the WRF-Chem support section of this forum so their group can assist you.
 
my understanding, as stated previously, the model for an unknown reason issues the error message when writing wrfrst file. I increased the number and ovoid them. The model passed this step.
 
Top