Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Save history file only for specified domains


New member
Is it possible to save history files only for specified domain to reduce storage consumption? I guess one could use history_interval to have less frames for the other domains, but maybe there exists a more clean way to obtain a solution here?
This thread may help you.

Also these are the options for the namelist.input file for wrf and wps.

Thanks for your answer. I had a look into that thread and it did not work out for me, it seems to me that these "inputout..." settings control the input data "wrfinput_d<domain>_<date>" instead of the history output data files. Also, when I try to add these options I get errors (the namelist is not well described on this imo).
------ ERROR while reading namelist time_control ------
Maybe here?: inputout_begin_y = 0, 0, 0, 0,
Maybe here?: inputout_begin_mo = 0, 0, 0, 0,

I'm running WRF Model Version 4.3


  • namelist.input
    3.4 KB · Views: 3
  • namelist.wps
    1.1 KB · Views: 0
If you are only interested in writing history output for one of your domains, you can set the other to zero. For e.g.,
history_interval = 0, 60
This would not write any history files for d01, and would write them every hour for d02.
Setting history_interval (or history_interval_s) equal to zero for a domain seems not to give any simulation at all. Attached is the output (no errors produced). Did I miss something here?


  • namelist.input
    3.1 KB · Views: 2
  • namelist.wps
    1.1 KB · Views: 1
  • rsl.error.txt
    1.8 KB · Views: 0
  • rsl.out.txt
    1.8 KB · Views: 1
I believe this is because you're using adaptive time-stepping, and you have "step_to_output_time = .true." Can you set that to .false. and see if it fixes the issue?
Yes, that gave at least a simulation, but the history is still written to file for the other domains (but only two frames for some reason) with history_interval=0.


  • namelist.input
    3 KB · Views: 3
  • namelist.wps
    1.1 KB · Views: 0
I'm not sure why it would be still writing to the wrfout* files for d01, d02, and d03. I just ran a test with a similar set-up and I'm only getting history files for the domain that isn't set to 0. Can you run the test again, and then issue this command from your running directory

ls -ls >& ls.txt

and then attach that ls.txt file, along with the full rsl.out.0000 file? Thanks!