Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Ungrib file lost isobaric levels

Tam Nguyen

New member
Dear all,

I'm currently running WRF with ERA5 for a few specific years. I've done a few test runs, which did fine. However, when I run with data from 1964, ungrib.exe produces FILE that lost levels in RH, TT, PRES,... The problem is that metgrid.exe and ungrib.exe stills run successfully without warning. I only found out when running real.exe and got "Trapping at x location."
When I ncdump the met_em files, I got a few variables without num_metgrid_level, and the MemoryOrder doesn't have verticle coordinates like this:
float RH(Time, south_north, west_east) ;
RH:FieldType = 104 ;
RH:MemoryOrder = "XY " ;
RH:units = "%" ;
RH:description = "Relative Humidity" ;
RH:stagger = "M" ;
RH:sr_x = 1 ;
RH:sr_y = 1 ;

I'm using the Vtable.ECMWF, therefore should not be different between the files I run for this time period and others.

I have checked my input grib file, which has the full 33 levels like I've requested, and tried to run ungrib.exe again a few times but this issue remains.

I've attached below my namelist.wps in WPS, namelist.input in WRF/test, ncdump_test file which detailed one of met_em files, list input files of 1964.
 

Attachments

  • ncdump_test.txt
    21.6 KB · Views: 1
  • namelist.input
    4.5 KB · Views: 0
  • namelist.wps
    960 bytes · Views: 0
  • list of variables.txt
    1.3 KB · Views: 3
  • read_test.txt
    43.4 KB · Views: 2
Where did you download the ERA5 data of 1964? Can you upload a single ERA file that has the level issue?
 
Dear Ming Chen,
I download the ERA5 data from the main website. I have attached the ERA file for temperature in pressure levels. Since a single file is quite big, I have separated it into 2 parts since it's convenient to download through API.

Link:
Temperature (first half): temperature_1964_a.grib
Temperature (second half): temperature_1964_b.grib

Best regards,
 
Hi,
It seems that for the datafile you have, a single file contains multiple times of data. WPS will have trouble to process such datafile. Usually WPS can only process files that contain data at single time.
 
Dear Minh Chen,
I also understand that situation. However, when I run the same type of files for other time period, there's no such error occurring so I'm quite curious why it happens to only this year.
 
Top