Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF QNSE PBL

mughalo

New member
Dear WRF users

I am using WRF version 4.0 and I am trying different PBL schemes. All of the schemes work except for QNSE scheme. The model crashes with a segmentation fault error when the radiation scheme is called. Seems like no issue with the radiation scheme, but more likely, that’s where the error gets picked up. I noted that whichever radiation scheme (lw/sw) or microphysics scheme I use, the length of the simulation always is equal to the value I set for “radt” in the namelist.input. Also tried with both with ERA5 and NCEP data reanalysis data but it didnt work. Also tried lower Fortran optimization, -O2 or -O1 rather than -O3 but nothing seem to work. I am attaching the recent namelist.input to this post.
I would be grateful if someone can point me to the error.
 

Attachments

  • namelist.txt
    4.7 KB · Views: 6
Hi,
The namelist looks fine except that the cumulus scheme should be turned on for the 18km domain, i.e.,
cu_physics = 1, 0, 0,

You can also set a larger time step, i..e,
time_step = 72 (or 90)

Also, this is a triply-nested case, which makes it hard to debug what is wrong. I wonder whether you can run this case over a single domain (i.e., max_dom=1) ? This will help us to narrow down possible issues.

Since the grid number is pretty small (50 x 50), I suggest you run this case with no more than 4 processors.
 
Hi
Thanks for your prompt response. I have submitted the runs with the options you have provided.
Do you mean to only use 4 processors from a single node ? I am currently using the following

SBATCH --ntasks=96
SBATCH --ntasks-per-node=24
SBATCH --time=00:30:00

This allows me to select 4 nodes with 24 tasks per node.
 
Please see the rsl.error files for each of the options used above. None of them worked for me.
 

Attachments

  • rsl.error_single_domain.0000
    5.6 KB · Views: 3
  • rsl.error_time_step_90.0000
    18.9 KB · Views: 0
  • rsl.error_time_step72.0000
    19.6 KB · Views: 0
The number of processors are too large for this case. You may need to run with a single node and use only 4 processors out of the 24.
With such a large number of processors you are using at present, domain decomposition would be wrong.
 
I reduced to 4 processors but I still see the same problem. I am not sure about the issue
Hi
Where you able to solve the issue?
I am facing the same error. Model is working fine for all other pbl_schemes except QNSE.

I gives a segmentation error after a few time steps.
I am attaching the namelist and rsl error log.

Looking forward to any kind of help.
 

Attachments

  • namelist.input
    4.6 KB · Views: 1
  • rsl.error.0000
    21.7 KB · Views: 3
  • rsl.out.0000
    19.6 KB · Views: 1
No sorry was still not able to resolve the problem.
Probably Jimmy Dudhia can help us out here. I think it has something to do with its link to the radiation schemes and with the landsurface model. But not sure
 
Top