Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

geogrid.exe cannot be executed properly

Eric Yip

New member
Dear all,

I was trying to execute geogrid.exe of WPS-3.9.1 by the command ./geogrid.exe, but the system did not show any message, and geogrid.exe cannot be executed, it just stuck forever as the screenshot shows.


When I tried to interrupt the progress manually by ctrl+c, the error message was recorded in the geogrid.log file. I also attach my namelist.wps file here.

Could you please advise on how to fix this? Or could this be the issue related to the resource availability of the HPC I'm using?


  • geogrid.log.txt
    1.6 KB · Views: 4
  • namelist.wps
    1.6 KB · Views: 1
Dear all, I have contacted the server admin and solved this problem. The reason for this situation is that I set the wrong mpi module and some conflicts occurred when geogrid.exe was calling the dynamic libraries. I was using mpich_icc before, but now I have changed to intelmpi. I'm using WPS-3.9.1 and successfully ran this case after fixing this problem.