Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Issues compiling WRF for ideal cases


New member
I am trying to run the ideal supercell case using WRF on Cheyenne. I have copied the version of the model I am interested in (WRFV4.1.3_intel_dmpar) to my own directory and found a few other responses here in regard to compiling the code myself (idealize supercell strom, Ideal.exe using pre-compiled code on Cheyenne). When I first try to do ./clean - a, I get a bunch of 'Permission Denied' messages. So moving forward, I tried to do ./configure and select the compiler and compiler mode, but when I did this, I get a message saying, 'One of compilers testing failed! Please check your compiler.' I am unsure of what this means or how to do this or even how to get around this and get the model properly set up for running my ideal case. Thank you for all and any help!
I'm not sure why you are getting permission errors when you run ./clean -a. I just tested it and I'm able to run that command without any problems (as myself - not as 'wrfhelp'). When you copy to your own directory, are you issuing something like (from your directory):

cp /glade/work/wrfhelp/PRE_COMPILED_CODE/WRFV4.1.3_intel_dmpar .

If you are using the above command to copy the full directory to your directory and still get permission issues when trying to clean the code, I would contact the CISL support group to ask for suggestions. There may be some odd environment setting in your account that is causing the problem.

The reason for the compiler issues is that you weren't able to clean the code, and therefore it's probably looking for the older compilers used to compile that particular version. An alternative is that you don't really need to clean and reconfigure the code to compile the idealized supercell case. Because it's a 3D case, you should be able to use the same configuration set-up. Therefore, you would just need to recompile with
./compile em_quarter_ss >& compile.log

To do this, though, you would need to swap out your compiler to the version that was originally used to compile (Intel V18.0.5).
module load intel/18.0.5
Okay, thank you! When I copied it, I was in the PRE_COMPILED_CODE directory and did:
cp -r WRFV4.1.3_intel_dmpar /glade/scratch/mfranke
but I followed the instructions you gave above and I was able to run ./clean -a. Except now, whenever I try to run ./configure I get an error saying, 'No environment variable NETCDF set. Stopping'
Last edited:
Yes, you will need to have a NETCDF environment variable set. Did you load intel/18.0.5? It looks like that compiler doesn't automatically set the netcdf variable. Try also setting
module load netcdf
Great! I was able to get everything going and believe I have it compiled correctly as well. Thanks for your help!