Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Real.exe produces only one wrfinput_d01 although I'm using 4 domains!


New member
I hope you're all doing great.

This is my first time using WRF,
I have done most of the WPS work, the geogrid, ungrib and metgrid and I linked my met output files to my wrf/run path.
My case study has 4 nested domains and I have attached the namelist.wps below.
When I run the real.exe and it runs successfully with no error message but produces only one wrf input file wrdinput_d01
I attached the the rsl messages as well that don't say any error in the process which is weird because I have 4 nested domains?!

1) I used NCEP Final Analysis (GFS-FNL) for data -6 hourly data
2) I'm using WRF V 4.1
3) I'm using a precompiled version on HPC by the Cyprus Institute (Cyclone)

Help would be very much appreciated!
Can you send me your nameist.wps and namelist.input to take a look?
I am not able to produce the input files for domains 3 and 4 while running real.exe. However, it is able to produce input files for the first two domains. I have been using WRF for several years, but with a newer version 4.3.3, am getting this issue. Can you help Ming?
Please send me your namelist.input and namelist.wps to take a look.
I am sending both namelist files attached in pdf formats. I tried 3 domain and 4 domain options. In these namelists, 3 domain options considered. I am also considering new terrestrial data sets as well. It has improved the smooth running of the WPS but the problem persists that is non creation of third domain initial condition. That is quite strange!!!


  • namelist-input.pdf
    71 KB · Views: 5
  • namelist-wps.pdf
    65.9 KB · Views: 2
I'm not ready to deliver the information documents for spaces 3 and 4 while running real.exe. In any case, creating input records for the initial two domains is capable. I have been involving WRF for a considerable length of time, yet with a more current variant 4.3.3, am getting this issue. Could you at any point help Ming?
Please contact me here: manana-wrfinput_d01-although-im-using-4-domains.11834/#post-27357
In your namelist.input, please reset the options below from:

dx = 27000, 9000, 3000, 2000,

dy = 27000, 9000, 3000, 2000,


dx = 27000, 9000, 3000, 1000,

dy = 27000, 9000, 3000, 1000,

All other options look fine. The reason that wrfinput for D03 and D04 are not created is probably due to the large grid numbers for the two domains. Please make sure that :
(1) you set large file support during compiling
(2) you run the case with sufficient space and memory

By the way, does this case run successfully?