Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Segmentation fault


New member

I am running the following simulation (see namelist attached), which works fine for some selected days but not for others. For the one attached here it crashes after some time without any clear error message.I tried reducing the timestep from 10 to 1 and also added ulimit -s unlimited, but this did not help.

I hope you can help,

Thank you,


  • log.wrf.txt
    5.8 KB · Views: 4
  • namelist.txt
    7.7 KB · Views: 2
  • rsl.error.txt
    9.6 KB · Views: 5
  • rsl.out.txt
    9.6 KB · Views: 3
I'm looking at your namelist and I'm a little confused about your domain. Based on the i/j_parent_start, parent_id, and parent_grid_ratio, It looks like domains 3, 4, and 5 are all the exact same domain - in the exact same place inside domain 2. If so, that's not necessary and this should only be a 3 domain simulation.

 parent_id                           = 1,     1,     2,    2,   2,
 i_parent_start                      = 1,    40,    105,  105,  105,
 j_parent_start                       = 1,    70,    105,  105,  105,
 parent_grid_ratio                   = 1,     3,     3,    3,   3,

is this perhaps an error in the namelist?
Thanks for that clarification. You mentioned that you decreased the time_step from 10 to 1. Is this because you were getting CFL errors initially? If so, then there are some other options for overcoming CFL errors, which you can read about in this FAQ. You can also read about some other potential contributing factors there, such as the size of the files, disk space, etc. Often when the model stops immediately, it's due to the input data, and since this only happens for certain dates, it's possible that's the issue.

I would also recommend seeing if any of the other rsl files have an error message in them. If you issue
ls -ls rsl.*
you can see the size of each rsl file. Typically the *.0000 file is the largest, but if you notice any other files have a larger size than most others, check to see if there is any useful information in it.

If none of that helps, check out this FAQ for ways to debug the code.

Thank you for your suggestions. No I did not have any cfl errors, I just tried different things to see if it would solve the problem. For me the first rsl file is stil the largest. I will need to debug the code and see if I can solve the problem.

Thank you,
Did you solve the problem? I had a similar problem with the urban canopy model in WRF 4.4, I ran it in January with no problems, but in the summer run, it kept getting segmentation errors, and it still hasn't been solved.
Segmentation fault could be caused by insufficient memory or because physics went wrong. Since your case can run in the winter, I am suspicious that the model crash in summer is caused by issues in the physics. Please look at your wrfout files and see whether you can find unreasonable values of any variable.
Also, in addition to the segmentation fault, did you find other error message in your rsl files?