Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

tail rsl.error.0000 is missing & -Dstubmpi error - please help!!!

vilic4

New member
I was able to run real successfully but when I search for rsl.error.0000, the file is not found.

1698069697028.png

also I'm getting this error -Dstubmpi option.


1698069673161.png
 

Attachments

  • namelist.wps
    777 bytes · Views: 1
  • namelist.input
    3.7 KB · Views: 1
Hi,
I have deleted some of your other posts regarding this error because you've posted it in several places in the forum. In an effort to keep the forum organized and easy to read, and also to keep multiple team members from working on the same issue simultaneously, we want to keep the correspondence with a single user and single issue in the same place.

Regarding this error, can you let me know what you did to try to fix it?
1) Did you compile the model for a parallel simulation (dmpar)? Please attach your configure.wrf file.
2) Do you have your paths set to find the MPI that you built the model with? Can you issue the command
Code:
which mpif90 >& mpif90.txt
and attach the mpif90.txt file?
 
Hi,
I'm confused by your latest message. The fact that you do have a path to mpif90 seems to indicate that you did install mpich. I'm not sure what the above "configure error" message is in reference to. What are you issuing to get that message? Is this a new issue, or is it related? Can you actually attach the full configure.wrf file, instead of just pasting a screenshot? Thanks.
 
Sorry for the confusion. I have attached the configure.wrf

I was not able to successfully install mpich 3.0.4 so I'm installing mpich 4.1.2 which might fix the Fortran compiler error..


Hi,
I'm confused by your latest message. The fact that you do have a path to mpif90 seems to indicate that you did install mpich. I'm not sure what the above "configure error" message is in reference to. What are you issuing to get that message? Is this a new issue, or is it related? Can you actually attach the full configure.wrf file, instead of just pasting a screenshot? Thanks.
 
@kwerner First of all, thank you for all your help. attaching configure.wrf in the post was not working so I converted it to txt. Please see the previous posting. Also I have installed mpich 4.1.2 but did not fix the issue. Any suggestions??? thanks..
 
Thanks for attaching the configure.wrf file. I believe the issue you're seeing is due to the fact that you did not compile the model with a "dmpar" option, but you're trying to use and "mpirun" command to run the model. This command requires that the model is built with distributed memory (dmpar - which should be chosen during configure). You currently have chosen a "serial" option (see this line in your configure.wrf file):

Code:
# Settings for    Linux x86_64 ppc64le, gfortran compiler with gcc   (serial)
 
Thanks for attaching the configure.wrf file. I believe the issue you're seeing is due to the fact that you did not compile the model with a "dmpar" option, but you're trying to use and "mpirun" command to run the model. This command requires that the model is built with distributed memory (dmpar - which should be chosen during configure). You currently have chosen a "serial" option (see this line in your configure.wrf file):

Code:
# Settings for    Linux x86_64 ppc64le, gfortran compiler with gcc   (serial)
@kwerner may i have your email? I would like to reach out to you directly

or would you email me, vilic4@gmail.com thanks
 
Hi,
Unfortunately we are urged to communicate on the forum since the conversations are searchable by the public and can help others in the future.
 
Three questions.

1. Where do I set this configure option? I noticed there are two ./configure

WPS folder? or WRF?

2. How do I know which one is the correct option?

This is what I have..
Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz 3.60 GHz


3. in the namelist.input, do I need e_vert? what is e_vert?



Again, thank you for all your help!!!
 

Attachments

  • 11.JPG
    11.JPG
    192.2 KB · Views: 3
Last edited:
@kwerner would you be able to help me with this question? thanks...
Apologies for the delay. Due to other responsibilities we have, we are not always able to answer forum questions immediately. It can sometimes take several days. Thank you for your patience.

1. Where do I set this configure option? I noticed there are two ./configure
WPS folder? or WRF?
Since the issue you are having is with the WRF model, you would need to do this in the WRF directory. When you issue "./configure," you should be given a list of compiling options. This is where you will need to choose the 'dmpar' option if you wish to run in parallel.

2. How do I know which one is the correct option?
This is what I have..
Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz 3.60 GHz
You will need to choose one of the Intel options, but I'm not exactly sure which is correct for your particular environment. I would guess option "15," would be correct, but I can't say for sure. If you need help with that, you should contact a systems administrator from your institution, who will know more about your environment.

3. in the namelist.input, do I need e_vert? what is e_vert?
Yes, you do. This is the number of vertical levels in the model simulation. You can find information about all namelist parameters in the WRF/run/README.namelist file.
 
Top