Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Troubles, could not find trapping x locations

Hi all,
I am using WRF4.2 to downscale CMIP6 data and I get the following error while running real.exe:

-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE:  <stdin>  LINE:    5868
troubles, could not find trapping x locations

According to previous posts ( I tried to increase/decrease p_top, e_vert and I also changed interp_type and the number of cores ( but nothing works.
The odd part is that both real.exe and wrf.exe ran successfully over the historical period (from 1980 to 2014), but when I provide the first date of ssp585 (2015-01-01-00) I get the error mentioned before.
I looked at met_em* files and I do not see any missing data both horizontally and vertically. Now, I cannot understand what is happening and how to fix this issue. I attach the namelists, the rsl.out and a sample met_em file. Do you have any suggestion?


    13.6 MB · Views: 34
I found no surface data in your met_em file. Please try the following options:
lowest_lev_from_sfc = .false.
force_sfc_in_vinterp = 0
use_surface = .false.

let me know whether these options can make the case run successfully. Thanks.
Hi Ming,
thanks for the suggestions, I tried to run real.exe but it did not work with your proposed changes.
Actually I do not understand why I can perform without any problem the simulations up 2014 and from 2015 I get this issue; I looked again at the met_em files for 2015 and they do not differ from previous years.
I have uploaded on Nextcloud a file named; it contains the grib data I prepared from a global ESM as well as Vtable and METGRID files I used in WPS. May I kindly ask you to cross check what differs between 1980 and 2015 and why there are no surface data in met_em although they are in the gribfiles?

Thanks again for the support,
Hi All,
since my last post, I realized geopotential heigh was missing as 3D input field. So, I added this variable, but I still get the same error while running real.exe.
I attach a subset of my input data and the namelists I used. Does anybody have some suggestion to understand what is going wrong?

Any hints will be greatly appreciated!


    38.7 MB · Views: 38
hello,I am sorry to bother you. I am using the 3.6 version of WRF and NCEP data of 2018. I have encountered the same problem, how did you solve it?

I do not remember exactly what was wrong, but in my case this error was related to a missing 2D variable in the first or second time step of my input forcing.

Hope it helps,