Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Ungrib.exe fails to process input GRIB files


New member
Hello to all.

I am in the process of attempting to ungrib ERA-5 Reanalysis 0.25-degree data available from the UCAR Research Data Archive for simulating Hurricane Ivan. I am used to routinely having to reobtain ERA-5 data and model outputs as the supercomputer I perform tasks on purges the data every so often, so I'm familiar with the routines of running WPS and WRF v4.3.0 itself.

I'm encountering an error with ungrib where it's parsing through my reanalyses and generating the pfiles, but it stops before processing them with the following error:
2022-09-09 20:08:49.504 --- INFORM: First pass done, doing a reprocess
2022-09-09 20:08:49.588 --- ERROR: Unrecognized map%igrid: 721 in RRPR 1

The above was attempted with only necessary data included.

When I attempted this with all ERA5 data available used as inputs for the time range I am interested in, I received the same error, but with a random number like 1203982336 instead of 721 (the latter of which corresponded with the number of gridpoints along a line of longitude in the reanalyses data).

I have attempted this with the full dataset, a dataset with only what is necessary, I have tried recompiling WPS and WRF to fix the issue, but none of these appear to be fixing the issue and I have never encountered this issue until a couple of days ago.

I am also using the ECMWF Vtable for the ungrib process and have tested it on a single file, which it worked for, but am uncertain why this would be occurring with a dataset that I have previously not encountered any problems with until now.

Does anyone have any ideas as to what might be the issue occurring here? I would greatly appreciate any assistance that could be offered!

EDIT: Added corresponding namelist and an ungrib log corresponding to a test run I performed.


  • namelist.wps.txt
    786 bytes · Views: 9
  • ungrib.log
    4.4 MB · Views: 7
Last edited:
This could potentially be a problem with the actual input data for 2004-09-20_00. Have you taken a look at the data? Is it the same size as other dates/times? Have you tried plotting the data? A couple other tests you could do to provide more information are to run ungrib only through 2004-09-19_21 to see if that completes. You can also try to only run ungrib for 2004-09-20_00 to make sure that's still failing. If it is, it's likely a data issue and you may need to contact the RDA to see if they have any suggestions for you. If you do figure it out, please update this post to potentially help other users!