Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

ungrib.exe not executing second pass through to replace PFILE


New member
I have just run into a new problem when trying to run ungrib on some NAM grib2 files. the program creates the temporary PFILEs, but cannot proceed with the reprocessing, with the following message:
forrtl: No such file or directory
forrtl: severe (29): file not found, unit 10, file /<WPS_directory>/NAM:2023-09-08_06

I renamed the file to have the prefix "NAM" as I want to run another simulation with GFS data.

I also noticed this has been an issue for others, but the solutions posted on the forum did not work for me. I re-configured and recompiled in serial with an intel compiler. See the configure.wps, log.compile, ungrib.log, and namelist.wps files attached.

I'm not sure what is going on, but some help would be greatly appreciated!

Thank you!


  • configure.wps
    3.3 KB · Views: 0
  • namelist.wps
    839 bytes · Views: 1
  • ungrib.log
    98.8 KB · Views: 3
  • log-compile.txt
    87 KB · Views: 1
Would you please send me the list of your GRIBFILEs? I am suspicious the error is caused by incorrect GRIBFILEs you ungribbed.

In your namelist.wps, you specify the time as:

start_date = '2023-09-08_07:00:00','2023-09-08_07:00:00','2023-09-08_07:00:00',
end_date = '2023-09-09_07:00:00','2023-09-09_07:00:00','2023-09-09_07:00:00',
interval_seconds = 10800,

But the code stopped at the time when it tried to produce data for 2023-09-09_07:00:00. This indicates that there are not enough input data.
Hi Ming,

Thank you for getting back to me. I tried again by downloading an additional file, but that also did not work. Here is a screenshot of my WPS directory. I thought I had enough input data to cover the range I needed.