Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

wrf 4.5 & 4.4 chem compile issue attached log file


New member
hello there, i am trying to install wrf chem model, everything goes well when i try to compile, it show this error "Problems building executables, look for errors in the build log" i went to log file and check the error "ERROR: variable name for third body in KPP species file is expected to be M, but was not found in cbm4 species file" i had tried other versions like 4.4.1, 4.4 but still same issue. i don't know how to solve that i am trying to install wrf from last few weeks. please anyone help me how can i solve that? thanks


  • compile_wrf.log
    1.1 MB · Views: 9
i have fix this issue, i wasn't install flex library i install and export it path and it work fine for me. i was getting one more issue while compiling the wrf 4.5 it was "no reference found" i search and found that it was due to my wrong netcdf path i correct that path and it compile the wrf 4.5.
please I am also encounter the same error. previously, I compiled WRF and WPS successfully by disable-netcdf-4.
However, for coupling of WRF with WRF-hydro, it requires enabling-netcdf-4 and I create all the libraries but stacked at WRF Compiling stage.
please suggest me how to fix?


  • log.compile.txt
    285.3 KB · Views: 2
  • configure.wrf.txt
    20.7 KB · Views: 2
Last edited: