Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRF4.4.1 real.exe error


New member
Dear all,

I am in attempt to using WRF4.4.1 to run weather modelling by following the compiling tutorial: Compiling WRF.
My WRF Compiler Choice is 34 and nesting option is 1 while my WPS compiler choice is serial.
I have successfully configured and compiled WRF and WPS and passed all the library tests. The version of libraries I used are netcdf-4.1.3, jasper-1.900.1, libng-1.2.50, mpich-3.0.4, zlib-1.2.7.

Under the real-time data section, I have chose to download gfs data on 30/06/2021 for 6 hours interval, 00,06, and 12.

I have taken the following actions in the WPS directory.
My geogrid was executed successfully with and
However, when I ran ungrib for three files, only one GRIBFILE is produced, that is GRIBFILE.AAA and only one nc file is produced. Hence, I have to edit my namelist for each date and repeat the run geogrid and ungrib to produce the FILE for metgrid.
after i execute the command
./metgrid.exe >& log.metgrid
for each case, met_em file is produced.

Then, I went into WRF file and edit my namelist.
I also copied the met_em files in the WRF files.

However, when I run the real program, the following error comes out.

Missing surface temp, replaced with closest level, use_surface set to false.
Missing surface RH, replaced with closest level, use_surface set to false.
Missing surface u wind, replaced with closest level, use_surface set to false.
Missing surface v wind, replaced with closest level, use_surface set to false.
ERROR in psfc: flag_psfc = 0, flag_soilhgt = 0, flag_slp = 0, sfcp_to_sfcp = T
-------------- FATAL CALLED ---------------
not enough info for a p sfc computation
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0

I have repeat the above steps with another sets of most recent data that is on 06-10-2022 with 3 hours interval and the same issue pops out.

I have attached the namelist.input and namelist.wps and the rsl.error0000 as follows. Feel free to tell me if there is any additional files that is needed and I look forward to your assistance. Thank you.



  • rsl.error.0000
    2.1 KB · Views: 3
  • namelist.input
    3.7 KB · Views: 9
  • namelist.wps
    722 bytes · Views: 3

1) First, to address the issue you're having with ungrib only creating a single GRIBFILE, what command are you using to link in the input files? Do all the input files have the same prefix? If not, can you change the name of the files so that they do, and then make sure (from the WPS directory), you're issuing

./link_grib.csh <path-to-your-gfs-files>/<gfs-file-common-prefix>

Make sure you're not connecting to just the directory that holds the input files, and there is no need to complete the file names - just the common prefix will do. Note there is also not a "." at the end of that command, as the link_grib.csh script handles that for you.

2) As for the specific error you're seeing, according to your namelist.input file, you only have 16 metgrid levels (num_metgrid_levels), and zero soil levels (num_metgrid_soil_levels). Since you are trying a case from 2021, GFS data should have available 34 num_metgrid_levels, and 4 soil levels. Perhaps you could try to obtain the GFS code from a different source, such as from the RDA site. The difference is the data you are currently using has a resolution of 0.5 degrees, and the link I provided is for 0.25 degree data, but, theoretically, that should be better. For future reference, if you're curious about the mandatory input data to run WRF, take a look at this FAQ.

Thank you for the prompt reply.

1) I have executed the code for the first issue and it works out well. Thank you for the solution.

2) The GFS data works fine too! Now I have executed 7 wrf.out file for domain, d01. The files name were

When I viewed the dates insides the file, it seems that it only process this date and time ,2021-06-30_06:00:00. Is this the expected output? I have attached the namelist file, rsl.error and rsl.out file in this thread. Thank you.


  • rsl.error.0000
    24.9 KB · Views: 1
  • namelist.input
    3.7 KB · Views: 8
  • rsl.out.0000
    24 KB · Views: 0