Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

CFL error while running WRF-ARW


New member
Hello everyone,
I'm running some simulations with WRF version 4.5.1 coupled with sf_urban_physics = 2 and bl_pbl_physics = 8 for three one-way nested domains for a month. Initially, I defined the eta levels with auto_levels_opt = 2, dzbot = 35, dzstretch_s = 1.3, and dzstretch_u = 1.1. This way, I could run the wrf.exe for the whole period without issues.

Today, I decided to increase the level of detail at the model's surface, so I defined the eta levels manually, setting the thickness of the first 10 levels from the ground equal to 5 meters and then stretching from the eleventh up to the top of the atmosphere. The p_top_requested = 5000.
While I could run real.exe, wrf.exe started, but at 00:01:10 of the first day of simulations, the model stopped without crashing or providing any errors except for the CFL ones found using the grep cfl rsl* command. I tried all the tips in the FAQ section related to CFL errors and segmentation faults, but nothing changed. Moreover, I tried to increase the debug level to obtain some other information about the issue, and I got this: "forrtl: error (78): process killed (SIGTERM)".

Can you please help me understand the problem and how to fix it?
Thank you in advance for any reply and for your time.

I uploaded on Nextcloud a folder named CFL_error_while_running_WRF-ARW which contains: the namelist.input with the auto_levels_opt activated, the namelist.input with the eta levels defined manually, and the rsl.files. In addition, I'm attaching the picture of the domains.


  • Domains.png
    81.6 KB · Views: 5
The 5 m thickness of vertical layers is way too small for the model to remain numerically stable.
With increasing horizontal resolution, vertical resolution can be adjusted accordingly. However, while there is no strict rules to govern how high it should be, the thickness of vertical levels usually shouldn't be smaller than 20-30m. Depending on the model top setting, we recommend 45 levels for p_top = 50 hpa and 60 or more levels for p_top = 1 hPa.
Thanks a lot, Ming, for your fast reply. I'll try to set up the namelist accordingly and re-run the model.