Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

Issue with real.exe and Nested Domains


New member
Hi all,

I am attempting to run a 24-hour simulation of a 3-nested domain over the North Atlantic on Cheyenne using the pre-compiled WRF code under ~wrfhelp/. When I run ./real.exe, the output files of wrfbdy_d01, wrfinput_d01 and wrfinput_d02 are created, but wrfinput_d03 is not created.

I cannot find an error in any of the rsl.error files and the output showing in "tail rsl.error.0000" is similar to this post here: missing wrfinput_d02 file So ./real.exe appears to be failing but I cannot find an error anywhere.

I tried making the wrfinput files separate by changing the following but this did not help either (as was recommended in this archived post real exe stops running):
io_form_history = 102
io_form_boundary = 102
io_form_input = 102

I don't think there's a size issue with not creating wrfinput_d03 since wrfinput_d01 is 178M and wrfinput_d02 is 609M.

Attached are my namelists, zip files of the rsl.error and rsl.out files, the output file for the job on Cheyenne (real.o6083480).

Thank you for any help and insight you can provide!


    176.6 KB · Views: 3
    485.4 KB · Views: 1
  • namelist.input.txt
    4.2 KB · Views: 10
  • namelist.wps.txt
    831 bytes · Views: 3
  • real.o6083480.txt
    3.4 KB · Views: 2
One obvious error in your namelist.input is that, you should specify dx for each domain, i.e.,
dx = 27000, 9000, 3000,
dy = 27000, 9000, 3000,
Please change and rerun again.
Update: I changed the number of cores and processors in my PBS job submittal file to select=8:ncpus=36:mpiprocs=36 and it worked! I am not sure why it was not throwing an error for what apparently was a lack of processing power, but wrfinput_d03 has been successfully created. If you have any other ideas for solutions, please let me know. Thank you!
Thanks for the update and I am glad it works! I guess this is a memory issue. D03 has such a large number of grids, which requires a large memory to run. However, usually we will have a segmentation fault message when the memory is not sufficient. It is mysterious why this case doesn't issue any message. Anyway it is great you make it work!