Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

SIGSEGV, Segmentation fault occurred while running real.exe for a Nested case


New member
Greetings all,

I'm trying to run a nested , 5 months long case on a precompiled WRF system using ERA-5 both single and pressure level dataset and I used the following reference to download the data from:

WPS all ran successfully all the way to metgrid and everything is fine.
I linked the files and tried to run the real.exe file, it ran for a while then stopped. I checked the output error and this was what it said at the end:

metgrid input_wrf.F first_date_input = 2007-10-30_07:00:00
metgrid input_wrf.F first_date_nml = 2007-10-01_00:00:00
d01 2007-10-30_07:00:00 Timing for input 0 s.
d01 2007-10-30_07:00:00 flag_soil_layers read from met_em file is 1
Using sfcprs to compute psfc
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
real.exe 0000000002A729F3 for__signal_handl Unknown Unknown
libpthread-2.17.s 00002B6E4BF85630 Unknown Unknown Unknown
real.exe 0000000002B3CBAC __intel_avx_rep_m Unknown Unknown
real.exe 0000000002AD4DF6 for_trim Unknown Unknown
real.exe 000000000083DDB3 Unknown Unknown Unknown
real.exe 0000000000456B47 Unknown Unknown Unknown
real.exe 000000000045C936 Unknown Unknown Unknown
real.exe 000000000048768C Unknown Unknown Unknown
real.exe 000000000049E921 Unknown Unknown Unknown
real.exe 000000000041590C Unknown Unknown Unknown
real.exe 00000000004140D2 Unknown Unknown Unknown 00002B6E4C1B4555 __libc_start_main Unknown Unknown
real.exe 0000000000413FE9 Unknown Unknown Unknown


I'm using WRF V 4.1.3 and WPS 4.1, I already ran a nested case before successfully on the same system using a different dataset (NCEP Final Analysis GFS), domain and time settings (only one day run and 3 nested domains instead of 2 like this one).
I tried the
ulimit -s unlimited
command still same errors.
I attached everything including: Namelist.input, namelist.wps, rsl.0000.error and rsl.0000.out

Could this be a resources problem? Storage, processors? What should I do if that were the case? I'm running on a supercomputer and I could run on clusters but I never used clusters for a real.exe program??! Weird, right?

I need your help urgently and I appreciate you taking the time to read and try to sort this out for me.
Thanks in advance.


  • namelist.input
    4.6 KB · Views: 2
  • namelist.wps
    1.3 KB · Views: 2
  • rsl.error.0000
    517.8 KB · Views: 3
  • rsl.out.0000
    1.3 MB · Views: 2
When you process the ERA-5 data, are you including the invariant file, as described here?
No, I did not do this step actually. OK, so now I have to repeat the WPS process to make sure everything is right.
I will do this and come back to you. I hope it will fix things.
Just one quick question before I retry this;
this forum here: Initializing the WRF model with ERA5 (pressure level)
Mentions that I download only pressure level data and single level data then link "both" of them and work on them, is that correct? Or at least as the original poster described as a good approximation to or alternative to using model and surface dataset?
I'm not able to access the linked page you sent, but you should make sure to have the 3D atmospheric data (i.e., pressure level data) and the surface level data and you will need to use both of them.