Scheduled Downtime
On Friday 21 April 2023 @ 5pm MT, this website will be down for maintenance and expected to return online the morning of 24 April 2023 at the latest

WRFV4.4.2 compilation and gcc version


New member
Hi all,

I am new to installing the WRF model. I have a virtual machine with Linux RHEL 6.4, where I have previously installed WRF version 4.0.1, and I run the model daily for 48-hour forecasts.

I have tried to install the WRFV4.4.2, but I get the following warning before compiling:
************************** W A R N I N G ************************************

There are some IEEE Fortran 2003 features in WRF that your compiler does not recognize. The IEEE function calls have been removed.


And I get the following error during compilation:

Fatal Error: Can't find an intrinsic module named 'ieee_arithmetic' at (1)
0.05user 0.06system 0:00.11elapsed 97%CPU (0avgtext+0avgdata 6528maxresident)k184inputs+16outputs (0major+13460minor)pagefaults 0swaps
make[3]: [module_firebrand_spotting.o] Error 1 (ignored)

I have seen in some posts WRF v4.4 Compilation error, WRF v4.4.2 fails that this is due to the gcc version. The gcc version on my virtual machine is 4.4.7, and posts indicate that the solution may be to install a newer gcc version.

To compile correctly, what gcc version should I install for the WRF4.4.2? And another question, if installing a newer version of gcc on the server, would the execution of the WRF 4.0.1 model already compiled be affected, i.e., running ./wrf.exe would be executed correctly?

I appreciate your support on this issue.
Yes, it sounds like your issue is very likely related to your old version of GNU/gcc. The version of GNU/gcc we use, by default, on our NCAR HPC is V11.2.0, and it works well.

You shouldn't have any problems running your older-compiled WRF (with the older gcc), if you install a new gcc.